• Erich Pekar
    Teilnehmer
    Post count: 135
    #90741 |

    Hilfe gesucht :

    Nachdem ich mit  Raspberrry Zero  wieder einen Mikrocontroler einsetzen möchte, benötige ich dazu auch auf MicroSD “installierte”  Betriebsystem-Images. Unter Linux- Mint ist es mir aber nicht gelungen auf eine Micro-SD  ein Betriebsystemimage zu übertragen.
    Problem : SD  ist schreibgeschützt.

    Zunäst dachte ich nur an fehlende Erfahrung in Linux als Ursache für dieses Problem.
    Unter Windows 10 existiert dieses Problem bei mir aber genauso.
    Die (neue) SD- kann weder formatiert noch beschrieben werden – seltsamerweise  auch nicht mit Acronis Disk-Doctor 12 , ist aber dort (und im Windows Filesystem) mit unformatierter Partition sichtbar.
    Das Problem ist auch nicht auf  eine bestimmte (vielleicht beschädigte) MicroSD beschränkt.
    Und zumindest eine  problematische MicroSD  konnte in einer Digitalkamera problemlos gelöscht und neu formatiert werden.

    Die zur Lösung  vorgeschlagenene 3 Methoden im Internet ( DiskPart, Windows-Registry, PlattenManager eines Drittherstellers )  bringen nicht nur bei mir nicht den gewünschten Erfolg – es gibt zahlreiche Klagen über nicht gelungene “Reparaturversuche”  ( zur Entfernung des Schreibschutzes ).

    Einzig eine alte, 2 GByte große, MMC-Card  scheint auch unter Linux ohne Probleme ( mit sonst vorhandenem aktiviertem Schreibschutz) zu funktionieren; auf ihr könnte ich das Image für den Raspberry Zero  speichern, dafür benötige ich aber das MicroSD-Format.

    Wennn nicht mein fast neuer  SD-Reader ( als Fronteinschub im PC, vielleicht ein Staubproblem und daher mangelhafte Kontaktgabe der MicroSD-Karte ? )  ein bisher nicht bemerktes technisches Problem hat, dann habe ich keine Idee, wie ich die Ursache des Problems noch weiter eingrenzen könnte.

    Habt ihr schon mal Probleme mit schreibgeschützten MicroSD gehabt, deren Schutz auch nicht temporär aufgehoben werden konnte ?

     

     

     

     

     

     

  • Erich Pekar
    Teilnehmer
    Post count: 135
    #90750 |

    Problem  gelöst :

    Ursache war die zu alte Hardware  des Card-Readers. Mit offenbar neuerem (externen) Cardreader ( mit USB 3.0 Interface) tritt das Problem  nun nicht mehr auf.
    Leider ist auf internen und externen Cradreadern halt kaum erkennbar, für welche SD-Karten ( -Speicher-Größen)  diese verwendbar sind.
    Das Image für den Raspberry Zero konnte nun erfolgreich auf die 16 GB SD-Karte geschrieben werden.

     

     

You must be logged in to reply to this topic.